Android 2.x版本使用Fragment

Fragment是3.0以上版本的新特性,如果需要在低版本的Android上使用,要导入Google提供的android-support-v4.jar包.
但在导入后,使用方法与3.0以是版本自带的Fragment稍有不同.
首先,所有的Fragment的类,必须使用android.support.v4.app下的类,不能用android.app中的类。
Activity必须继承自FragmentActivity,获取FragmentManager对象使用getSupportFragmentManager()方法,而不是getFragmentManager()方法.

© 2012, 冰冻鱼. 请尊重作者劳动成果,复制转载保留本站链接! 应用开发笔记