Android开发:创建向后兼容的UI–使用版本相关组件

翻自http://developer.android.com/training/backward-compatible-ui/older-implementation.html

现在你已经有了两个TabHelper 和CompatTab的实现,一个针对Android 3.0以上版本,一个针对老版本。这节课讨论创建两个实现切换的逻辑,创建版本相关的布局,最终使用UI向后兼容组件。

添加切换逻辑
TabHelper抽象类扮演了一个创建合适版本的TabHelper和instances的工厂,基本当前设备平台版本。

public abstract class TabHelper {
    ...
    // Usage is TabHelper.createInstance(activity)
    public static TabHelper createInstance(FragmentActivity activity) {
        if (Build.VERSION.SDK_INT >= Build.VERSION_CODES.HONEYCOMB) {
            return new TabHelperHoneycomb(activity);
        } else {
            return new TabHelperEclair(activity);
        }
    }

    // Usage is mTabHelper.newTab("tag")
    public CompatTab newTab(String tag) {
        if (Build.VERSION.SDK_INT >= Build.VERSION_CODES.HONEYCOMB) {
            return new CompatTabHoneycomb(mActivity, tag);
        } else {
            return new CompatTabEclair(mActivity, tag);
        }
    }
    ...
}

创建版本相关的Activity布局
下一步是给Activity提供布局来支持两个标签实现.针对老平台实现(TabHelperEclair),你需要确保你的Activity布局包含一个TabWidget和TabHost:

res/layout/main.xml:




    

        

        

    

在TabHelperHoneycomb的实现中,你所需要的只是一个FrameLayout用来放内容,因为ActionBar提供了指示器
res/layout-v11/main.xml:


在运行时,Android会根据平台选择哪个版本的main.xml.这跟上一节说的决定用哪个TabHelper实现是一样的逻辑。

在Activity中使用TabHelper
在Activity里的onCreate()方法,你可以通过以下代码得到一个TabHelper对象,添加Tab

@Override
public void onCreate(Bundle savedInstanceState) {
    setContentView(R.layout.main);

    TabHelper tabHelper = TabHelper.createInstance(this);
    tabHelper.setUp();

    CompatTab photosTab = tabHelper
            .newTab("photos")
            .setText(R.string.tab_photos);
    tabHelper.addTab(photosTab);

    CompatTab videosTab = tabHelper
            .newTab("videos")
            .setText(R.string.tab_videos);
    tabHelper.addTab(videosTab);
}

当运行应用时,代码会载入正确的Activity布局,初始化TabHelperHoneycomb或TabHelperEclair对象。实际使用的类对Activity是不透明的,因为他们共享通用的TabHelper接口。
下面是两种实现的截图:

© 2014, 冰冻鱼. 请尊重作者劳动成果,复制转载保留本站链接! 应用开发笔记

发表评论

电子邮件地址不会被公开。 必填项已用*标注